activeMQ 5.1.0 pour OpenVMS

Publié le 15 Juillet 2008.

activeMQ est un message broker ainsi qu’un client JMS développé en Java sous licence Apache 2.0. Il communique à l’aide de plusieurs protocoles (Stomp, OpenWire, xmpp…) et supporte des clients en différents différents langages (C, C++, C#, Perl, PHP, Python, Ruby…).

activeMQ 5.1.0 a été porté sur OpenVMS. Le portage a consisté à modifier activeMQ afin d’éliminer une erreur de parsing, tester les principales fonctionnalités, écrire les procédures de démarrage et d’arrêt et créer un kit PCSI.

activeMQ pour OpenVMS nécessite Java 1.5.0 minimum et doit être installé sur un volume ODS5. activeMQ a été testé seulement sur Itanium. Le kit PCSI est basé sur l’archive officielle apache-activemq-5.1.0-bin.tar.gz et peut être téléchargé à :

activeMQ

Thierry Uso.

aleft Réunion HP-Interex JTrac 2.1.0 pour OpenVMS aright